Archived

This topic is now archived and is closed to further replies.

Guest MRC

Movie HD v1.0.8 (Mod Ad Free)

Recommended Posts

Guest MRC   
Guest MRC
Movie HD v1.0.8 (Mod Ad Free)

Requirements: 2.2+

Overview: Download the app to watch the latest Movie,TV Show in HD

 

fX6GL4A.png

 

Watch the latest movie and tv shows like Iron man, The Avengers, Game of Thrones and more.

- Easy to use

- Search, Download, Favorites

- 720p, 1080p and Fast Streaming

- User LocalCast for Chromecast/DLNA

- Updated everyday

 

Movie HD does not own or host any content. It simply aggregates links in a convenient, user-friendly interface. Please email any questions or concerns to [email protected] We will more than happy to comply with any DMCA requests.

 

This app has no advertisements

 

More Info:

https://play.google.com/store/apps/details?id=com.dndapps.moviehd.ui'>>https://play.google.com/store/apps/details?id=com.dndapps.moviehd.ui

Download Instructions:

 


 


Share this post


Link to post
Share on other sites

The latest version of this app. (v2.0.2) works fine on my Lollipop phone but crashes on my KiKat (v4.4.4) tablet.  Previous versions worked OK. 

Does anyone else have this problem with the latest version on kitkat 

Share this post


Link to post
Share on other sites
1 hour ago, fairytooth said:

Requires update then fails to install for me

Try downloading the new apk then go to Settings>Apps>Movie HD.  Force Close then Clear Cache>Delete Data>Uninstall. Then try installing the new apk.  

You can also get the v2.0.2 apk from 

https://filescdn.com/97qnf3gpy4b3

Mine installed ok and displays the movies ok,  but when you click on a movie it crashes. 

Share this post


Link to post
Share on other sites
26 minutes ago, gurukidd said:

Fast and easy download ad free also.

MediaFire link: Movie HD v1.0.8 (Mod Ad Free) - android-zone.ws(2).apk

http://www.mediafire.com/?ty8lmnwn6nep9oy

Sent from my SM-A500H using Tapatalk

Thanks Gurukidd. When you install and run v1.0.8 the first thing it does is upgrade you to v2.0.3. That version (v2.0.3) fixes my problem.

Share this post


Link to post
Share on other sites