Sign in to follow this  
Followers 0
jacksparrow

Xposed Installer v3.0 alpha 2 (for Android 5.1 only!)

13 posts in this topic

Xposed Installer v3.0 alpha 2 (for Android 5.1 only!)
Requirements: Android 5.1, ROOT
Overview: Xposed for Lollipop is finally here!
xposed.png
Note that this is still an alpha version and for Lollipop on ARMv7+ devices only.
Please install it only if you're willing to take the risk of boot loops. Just because it's working fine and stable for me doesn't mean it will work for everyone the same way.

Downloads
xposed-arm-*-5.1.zip - Must be flashed with a custom recovery to install the framework.
XposedInstaller_3.0-alpha*.apk - Must be installed to manage installed modules.
XposedBridgeApi-20150213.jar - The API for module developers, in case they want to make use of some new features. Might be changed slightly until the stable release!

Known Issues
Devices with very little free space on /system may have trouble installing. This installer has been tweaked slightly over the 5.0 installer. It will attempt to move your original libraries off /system, install the framework, compress the original libraries and then move the compressed originals back to the root of /system.
If Xposed for Android 5.0 didn't work on your device, its unlikely this one will either. This is more or less the exact same source code, just an updated ART runtime. But feel free to try, just make sure you know how to backup and restore.

How To Test
You must be on Android 5.1. It will NOT work on Android 5.0 (too many changes to ART).
You should have a working recovery (the busted ass "OEM" TWRP releases that don't have busybox are not "working recoveries"). The installer will try to detect this ahead of time.
If you left the Xposed app installed from Android 5.0, you should disable all modules before installing this framework. Busted modules may keep you from booting after installation otherwise.
I will need Xposed logs (and possibly logcats) to debug any issues. Remember, if your device won't boot after installation, its likely you can reboot to recovery and still grab the Xposed log (assuming Zygote started). It will be in /data/data/de.robv.android.xposed.installer/log as error.log or error.log.old.

Xposed 3.0 alpha 2
java.io.IOException: Invalid argument while reading /data/data/de.robv.android.xposed.installer/conf/modules.list (sometimes it worked fine after a soft reboot), see https://github.com/rovo89/Xposed/issues/25
ClassNotFoundException for system services (e.g. ActivityManagerService) shown in the log, see https://github.com/rovo89/XposedBrid...b429c7a7032afa
Resources-related incompatiblity on newer CM12-based ROMs
Hooks for very simple methods not working, see https://github.com/rovo89/android_art/issues/4
app_process version not displayed in XposedInstaller

This app has NO advertisements

More Info:

http://phandroid.com/2015/02/13/xposed-for-lollipop-is-now-available-for-root-users/'>>http://phandroid.com/2015/02/13/xposed-for-lollipop-is-now-available-for-root-users/
Download Instructions:

Xposed Installer v3.0 alpha 2 (for Android 5.1 only!).zip -  3.5 MB
 

Share this post


Link to post
Share on other sites

Work in Samsung note 4

 

Note 4 is not updated to 5.1 yet

 

 

 

 

 

56

i didn't know is a 5.1 android,i thought is just 5.01 and 5.02,but anyway,it means that all the rest with alder version not gonna get updates?

 

 

Older versions will get updates but we have wait for that

MOHMAD_NAGY likes this

Share this post


Link to post
Share on other sites

What about note 3 sm n900 lolipop

 

 

 

This will not work on samsung devices

 

 

 

 

Gave me bootloop as well aftr installing jst one MOD. . .

 

Gave me BootLop on my Nexus 5.1 after installing about 3 Mods. :thmbdn:

 

Don't use. Many good mods will give bootloop

And its not alpha 2 as that version is for 5.0.1

Its super alpha for 5.1

 

 

Yeah because mods are not updated to be compatible with 5.1 yet

Share this post


Link to post
Share on other sites

some mods are,


so dont state till you know


but they are all CRAP mods


the needed mods are bootlooping


and seems this super alpha has mass security issues


id suggest DONT INSTALL


rovo is looking into it


Itsme likes this

Share this post


Link to post
Share on other sites

Gave me BootLop on my Nexus 5.1 after installing about 3 Mods. :thmbdn:

Yes, I was thinking it would work, but after activating some mods, bootlooping, indeed...I didn't find which one fails...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0